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About This Document
This document describes end user system requirements for PeopleFluent Talent 
Management.

Audience
This document is intended for:

 System Administrators

 IT Staff

 End Users

 Note: This document assumes that you are familiar with the supported 
versions of the operating systems, web browsers, and typical office 
software.

Notice to Users
This document provides detailed information about the hardware and software you will 
need to use PeopleFluent Talent Management. 

This document is subject to revision based on external hardware and software changes; 
it will be updated periodically to reflect those changes.

PeopleFluent supports and provides defect fixes for PeopleFluent products under valid 
Support and Maintenance Agreements on only those operating systems and browser 
environment distributions that have been certified and published by PeopleFluent. While 
it may be possible to run PeopleFluent products on other, non-certified operating system 
or browser environment distributions, PeopleFluent makes no such representations or 
warranties, either express or implied. Additionally, PeopleFluent will not be responsible 
for providing any defect fixes for any such non-certified distributions. 

Document Revision
This section lists the initial publication and any changes or updates that follow.

Table 1: Revision Information

Revision Information

Revision Date: 22 June 2021

Document Version Number: 1.0

Details of Revision: Initial publication.
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Hardware and Software System Requirements
The following sections describe system requirements and information about setting up 
your computer for use with PeopleFluent Talent Management.

Workstation Requirements

Mobile Device Requirements 
To provide security and the best performance to our users, PeopleFluent clients who 
want to use mobile-enable features are recommended to use mobile devices with the 
latest stable release of Apple iOS or Google Android. 

Unsupported older versions of those operating systems may have rendering or 
compatibility issues. When such issues are reported, PeopleFluent will attempt to 
recreate on fully supported operating systems and in the event this cannot be replicated, 
the remedy will likely be a recommendation for clients to upgrade to a supported 
operating system.

Table 2:  Workstation Requirements

Requirement Definition

Operating System  Microsoft Windows 10
 Microsoft Windows 8.1
 macOS 10.13 or later

Memory Recommended: 2 GB RAM or more
Minimum: 1 GB RAM

Processor Speed Recommended: Dual Core, 1 GHz 
(or equivalent compatible processor)
Minimum: Pentium 4, 1 GHz

Monitor Resolution Recommended: 1280 x 1024 pixels or higher
Minimum: 1024 x 768 pixels

Monitor Size Recommended: 17 inch or larger
Minimum: 15 inch
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Web Browser Support Policy
To provide the best security and performance for our users, PeopleFluent recommends 
that clients use one of the following browsers to access PeopleFluent applications. 

Older browser versions may have rendering or compatibility issues. When such issues 
are reported, PeopleFluent will attempt to recreate on recent browser versions and in the 
event this cannot be replicated, the remedy will likely be a recommendation for clients to 
upgrade to one of the following  browsers. 

Microsoft Edge (latest stable release)
PeopleFluent supports the latest stable release of Microsoft Edge browsers in 
accordance with Microsoft’s support policy. 

Microsoft Internet Explorer
PeopleFluent supports Microsoft Internet Explorer browsers in accordance with 
Microsoft’s support policy: https://support.microsoft.com/en-us/help/17454/lifecycle-
faq-internet-explorer

Mozilla Firefox (latest stable release)
PeopleFluent supports Firefox’s latest stable release channel. PeopleFluent’s support 
also extends to Firefox’s specialised Extended Support Release (ESR). For Mozilla Firefox 
release notes, go to: https://www.mozilla.org/en-US/firefox/releases/ 

Google Chrome (latest stable release)
PeopleFluent supports Chrome’s latest stable release from Google Stable Channel.
For Chrome release updates, go to: 
https://chromereleases.googleblog.com/search/label/Stable%20updates

Apple Safari
PeopleFluent supports Safari browsers in accordance with Apple’s support policy. For 
more information, see: https://support.apple.com/en-us/HT204416
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Deprecated Browser Versions

Deprecated browser versions have been tested and found to have serious problems when 
used to access PeopleFluent Talent Management. 

 WARNING: Using any of the following deprecated browser versions may 
result in loss of functionality, data loss, or both: 

 Microsoft Internet Explorer 10 and below

 Microsoft Edge 14 and below

 Mozilla Firefox 59 and below

 Apple Safari 9 and below

 Google Chrome 66 and below

PeopleFluent strongly recommends that all clients update the browsers used 
to access PeopleFluent Talent Management to the browser’s latest stable 
release and to do so on a regular basis as the browser is updated. 

Known Issues and Limitations

PeopleFluent requires the latest patches be instaled for all supported web browser 
versions. The following are known issues or limitations of web browsers that may affect 
the use of PeopleFluent Talent Management:

 PeopleFluent Talent Management does not support printing from Apple Safari on any 
supported Microsoft Windows operating systems due to the browser’s limited 
printing support.

 PeopleFluent Talent Management does not support PDF-based online job forms or 
PDF-based master online job forms on Mozilla Firefox for the macOS.

 PeopleFluent Talent Management has known issues when rendering information in 
PDF-based online job forms on Safari. For more information, see the known issue in 
the Safari on the Mac section of this document.

 PDF form digital signature fields created using Nitro Pro are not supported on 
Onboarding PDF forms. 

 PeopleFluent Talent Management does not support using Compatibility mode with 
any version of Microsoft Internet Explorer.
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 PeopleFluent Talent Management does not support using Enterprise mode with any 
version of Microsoft Internet Explorer.

 PeopleFluent Talent Management requires native XMLHTTP support be enabled 
when using Microsoft Internet Explorer to access PeopleFluent Compensation 
worksheets with a fixed header. 

 PeopleFluent Talent Management does not support using the Undo function when 
editing text areas with any version of Microsoft Internet Explorer. This issue is caused 
by a functional limitation of the web browser.

 PeopleFluent Talent Management does not support browser-based or operating 
system-based magnification or zoom features due to inconsistencies in how 
browsers implement content and image scaling.

 Resizing dialog boxes to be smaller than the default size may occasionally result in 
some screen elements being cut off. For best results, keep the PeopleFluent Talent 
Management window maximised (to at least 1024 x 768), and do not resize dialog 
boxes smaller than they first appear.

 Candidates accessing PeopleFluent Recruiting Center career sites cannot upload 
files from Dropbox using Google Chrome on an Apple iPhone.

 Microsoft Edge does not support the ActiveX plug-in which is required to view PDFs 
with Adobe Acrobat and Adobe Reader in a web browser. As a workaround, use 
Microsoft Internet Explorer 11. For more information, see:  
https://helpx.adobe.com/acrobat/using/display-pdf-in-browser.html#Edge

 PeopleFluent Talent Management on Apple Safari does not support integration with 
PeopleFluent Learning. 

 PeopleFluent Compensation Command Center does not support Microsoft Internet 
Explorer version 11. 
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Web Browser Configuration

Microsoft Edge

 Note: This section provides configuration instructions for clients using 
Microsoft Edge version 79 or later. If you are using Microsoft Edge version 
44 (EdgeHTML 18), see Microsoft Edge (Version 44) in this document.

Clients need to make the following configuration changes to end-user browsers:

 Configure Pop-up Blockers on page 6

 Enable Cookies on page 8

 Enable JavaScript on page 10

 Open PDF Files Externally on page 11

 Configure for Proxy Servers on page 12

Administrator permissions may be required to perform browser configuration.

 Note: Microsoft Edge does not allow for modification of the browser cache 
size.

Configure Pop-up Blockers
Pop-up blockers must either be disabled or set to allow PeopleFluent sites. The required 
domain names provided in this section are subject to change based on your 
organisation’s implementation. Contact your PeopleFluent representative for more 
information.

 Note: Clients must also configure any third-party pop-up blockers such as 
NoScript.

To configure pop-up blockers
1 In the Edge address bar, type edge://settings.

2 Click Site permissions.

3 In Site permissions, click Pop-ups and redirects.
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4 In Pop-ups and redirects, either:

 Clear Block, then go to step 9; or

 Go to step 5 to add PeopleFluent sites as exceptions.

5 In Allow, click Add.

6 In the Add a site box, type [*.]peoplefluent.com.

7 Click Add.

8 Repeat the process to add:

Figure 1: Pop-ups and redirects

9 If finished making changes to your browser’s settings, close the tab.

 https://[*.]peopleclick.com  The KZO video public base URL

 https://[*.]peopleclick.eu.com  The PeopleFluent Talent 
Management base URL

 https://[*.]peoplefluent.eu.com

 https://[*.]linkedin.com
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Enable Cookies
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. The LinkedIn domain name is only required if your 
organisation is using LinkedIn integration features. The Google domain name is only 
required if your organisation is using Google Analytics. Contact your PeopleFluent 
representative for more information.

To enable cookies
1 In the Edge address bar, type edge://settings.

2 Click Site permissions.

3 In Site permissions, click Cookies and site data.

4 In Cookies and site data, either:

 Select Allow sites to save and read cookie data, then go to step 9; or

 Go to step 5 to add PeopleFluent sites as exceptions.

5 In Allow, click Add.

6 In the Add a site box, type [*.]peoplefluent.com.

7 Click Save.

8 Repeat the process to add:

 [*.].peopleclick.com  [*.].linkedin.com

 [*.].peopleclick.eu.com  The KZO video public base URL

 [*.].peoplefluent.eu.com  The PeopleFluent Talent 
Management base URL

 [*.].google.com
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Figure 2: Cookie and site data

9 If finished making changes to your browser’s settings, close the tab.



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Microsoft Edge

PeopleFluent Proprietary and Confidential 10

Enable JavaScript
JavaScript must be enabled in Edge. Clients must also configure any third-party Edge 
plug-ins that block JavaScript, such as NoScript.

To enable JavaScript
1 In the Edge address bar, type edge://settings.

2 Click Site permissions.

3 In Site permissions, click JavaScript.

4 In JavaScript, select Allow all sites to run JavaScript (recommended).

Figure 3: Site permissions / JavaScript

5 If finished making changes to your browser’s settings, close the tab.
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Open PDF Files Externally
For best results when using PDF-based documents with PeopleFluent Talent 
Management, the default Edge PDF Viewer must be disabled. This forces PDFs to open 
using the default application associated with the file format in Windows.

To open PDF files externally
1 In the Edge address bar, type edge://settings.

2 Click Privacy and security.

3 Click Site permissions.

4 In Site permissions, click PDF documents. 

5 Select Always open PDF files externally.

Figure 4: Site permissions / PDF documents

6 If finished making changes to your browser’s settings, close the tab.
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Configure for Proxy Servers
Microsoft Edge uses the same connection and proxy server settings as Windows. 

 Note: If client organisations use a proxy server, they need to use the same 
proxy server for all protocols. 

To configure for proxy servers
1 In the Edge address bar, type edge://settings.

2 Click System.

3 In System, click Open your computer’s proxy settings. 

4 Consult your operating system’s instructions to configure the proxy settings for your 
organisation’s proxy server.
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Microsoft Edge (Version 44)

 Note: This section provides configuration instructions for clients using 
Microsoft Edge version 44 (EdgeHTML 18). If you are using the new 
Chromium-based version 79 or later, see Microsoft Edge in this document.

In general, clients should experience no problems with Microsoft Edge using an 
Internet Zone security setting of Medium. Administrator permissions may be required to 
perform browser configuration. 

Additional configuration changes to end user browsers and Microsoft Windows Internet 
Options are required. This lists the changes based on where they are made within 
Microsoft Windows 10:

 Enable Cookies on page 14

 Configure Pop-up Blockers on page 17

 Add Trusted Sites on page 19

 Enable File Downloads on page 21

 Allow Saving of Encrypted Pages on page 23

 Enable HTTP 1.1 on page 25

 Enable TLS 1.1 and 1.2 on page 26

 Enable JavaScript on page 27

 Configure Browser Cache on page 28

 Configure for Printing on page 29

 Configure for Proxy Servers on page 30

 Caution: Clients need to restart Microsoft Edge after completing the 
configuration changes listed in this section.
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Enable Cookies
Users must configure Microsoft Edge to be allowed to store cookies.

To enable cookies
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

Figure 5: Search for Internet Options
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3 On the Privacy tab, click Advanced.

Figure 6: Internet Options - Privacy



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Microsoft Edge (Version 44)

PeopleFluent Proprietary and Confidential 16

4 In First-party Cookies, select Accept.

Figure 7: Internet Options - Privacy

5 Click OK to close the Advanced Privacy Settings window.

6 Click OK.
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Configure Pop-up Blockers
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. Contact your PeopleFluent representative for more 
information.

 Caution: Pop-up blockers must either be disabled or set to allow 
PeopleFluent Talent Management-related sites.

To configure pop-up blockers
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Privacy tab, click Settings.

Figure 8: Internet Options - Privacy
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4 In Address of website to allow, type *.peoplefluent.com, and then click Add.

5 Repeat the process to add:

Figure 9: Pop-up Blocker Settings

6 Click Close.

7 Click OK.

 *.peopleclick.com  The KZO video public base URL

 *.peopleclick.eu.com  The PeopleFluent Talent 
Management base URL

 *.peoplefluent.eu.com

 *.linkedin.com
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Add Trusted Sites
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. The LinkedIn domain name is only required if your 
organisation is using LinkedIn integration features. The Google domain name is only 
required if your organisation is using Google Analytics. Contact your PeopleFluent 
representative for more information.

To add trusted sites
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Security tab, click Trusted sites and then click Sites. 

Figure 10: Internet Options - Security
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4 In Add this website to the zone, type: https://*.peoplefluent.com, then click Add. 

5 Repeat the process to add:

Figure 11: Trusted sites

6 Click Close to close the Trusted sites window.

7 Click OK.

 https://*.peopleclick.com  https://*.linkedin.com

 https://*.peopleclick.eu.com  The KZO video public base URL

 https://*.peoplefluent.eu.com  The PeopleFluent Talent 
Management base URL

 https://*.google.com
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Enable File Downloads

To enable file downloads
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Security tab, click Trusted sites and then click Custom level. 

Figure 12: Internet Options - Security
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4 Go to Downloads > File download and select Enable.

Figure 13: Security Settings - File download

5 Click OK to close the Security Settings window.

6 Click OK.
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Allow Saving of Encrypted Pages

To allow saving of encrypted pages
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Advanced tab, go to Security.

4 Clear the Do not save encrypted pages to disk option. 

 Caution: Using this feature will adversely affect page performance.

Figure 14: Do not save encrypted pages to disk

5 Click OK.
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Enable Native XMLHTTP Support
PeopleFluent Talent Management requires native XMLHTTP support be enabled when 
using Microsoft Edge to view PeopleFluent Compensation worksheets with a fixed 
header. 

To enable native XMLHTTP support
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Advanced tab, go to Security.

4 Select the Enable native XMLHTTP support option. 

Figure 15: Enable native XMLHTTP support

5 Click OK.
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Enable HTTP 1.1 

To enable HTTP 1.1
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Advanced tab, go to HTTP settings.

4 Select Use HTTP 1.1.

5 Select Use HTTP 1.1 through proxy connections.

Figure 16: HTTP 1.1 Settings

6 Click OK.
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Enable TLS 1.1 and 1.2 

To enable TLS 1.1 and 1.2
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Advanced tab, go to Security.

4 Select Use TLS 1.1.

5 Select Use TLS 1.2.

Figure 17: TLS 1.1 and 1.2 Settings

6 Click OK.
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Enable JavaScript
JavaScript must be enabled in Microsoft Edge. 

To enable JavaScript
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the Security tab, click Trusted sites and then click Custom level.

4 Go to Scripting > Active scripting and select Enable.

 
Figure 18: Active Scripting

5 Click OK to close the Security Settings window.

6 Click OK.
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Configure Browser Cache

To configure browser cache
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the search results menu.

3 On the General tab, in Browsing history, click Settings.

4 In Check for newer versions of stored pages, select Automatically.

5 Make sure that Disk space to use is set to at least 512 MB.

Figure 19: Disk space to use

6 Click OK to close the Website Data Settings window.

7 Click OK.
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Configure for Printing
For best results, background colours and images should be included when printing from 
PeopleFluent Talent Management.

 Note: Page Setup for Microsoft Edge is configured in Microsoft Internet 
Explorer 11 because the configuration is shared across both browsers. 

To configure for printing
1 In Microsoft Edge, go to More Actions (...), then click Open in Internet Explorer 11. 

2 In Internet Explorer 11, press ALT and go to File > Page Setup.

Figure 20: Configure IE 11 for Printing

3 Select Print Background Colors and Images.

4 Click OK.
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Configure for Proxy Servers

 Note: If client organisations use a proxy server, they need to use the same 
proxy server for all protocols. 

To configure for proxy servers
1 In the Windows Search Box, type Internet Options. 

2 Click Internet Options when it appears in the Search Results menu.

3 On the Connections tab, click LAN settings.

4 Click Advanced, and select Use the same proxy server for all protocols.

Figure 21: Proxy Settings

5 Click OK to close the Proxy Settings window.

6 Click OK to close the Local Area Network (LAN) Settings window.

7 Click OK.
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Microsoft Internet Explorer
In general, clients should experience no problems with Internet Explorer using an 
Internet Zone security setting of Medium. (Tools > Internet Options > Security). 
Administrator permissions may be required to perform browser configuration. 

 Note: Configuration of Internet Explorer on Windows 8 for PeopleFluent 
Talent Management can only be completed in Desktop mode. 

Additionally, clients need to make the following configuration changes to end user 
browsers:

 Add Trusted Sites on page 32

 Enable File Downloads on page 34

 Configure Pop-up Blockers on page 35

 Enable Cookies on page 37

 Allow Saving of Encrypted Pages on page 38

 Enable Native XMLHTTP Support on page 39

 Enable HTTP 1.1 on page 40

 Enable TLS 1.1 and 1.2 on page 41

 Enable JavaScript on page 42

 Configure Browser Cache on page 43

 Configure for Printing on page 44

 Configure for Proxy Servers on page 45

 Caution: Clients need to restart Microsoft Internet Explorer after completing 
the configuration changes listed in this section.
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Add Trusted Sites
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. The LinkedIn domain name is only required if your 
organisation is using LinkedIn integration features. The Google domain name is only 
required if your organisation is using Google Analytics. Contact your PeopleFluent 
representative for more information.

To add trusted sites
1 Go to Tools > Internet options. 

2 On the Security tab, click Trusted sites and then click Sites. 

3 In Add this website to the zone, type:
https://*.peoplefluent.com and then click Add. 

4 Repeat the process to add:

 https://*.peopleclick.com  https://*.linkedin.com

 https://*.peopleclick.eu.com  The KZO video public base URL

 https://*.peoplefluent.eu.com  The PeopleFluent Talent 
Management base URL

 https://*.google.com
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Figure 22: Trusted sites

5 Click Close to close the Trusted sites window.

6 Click OK.
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Enable File Downloads

To enable file downloads
1 Go to Tools > Internet options. 

2 On the Security tab, click Trusted sites and then click Custom level. 

3 Go to Downloads > File download and select Enable.

Figure 23: Security Settings - File download

4 Click OK to close the Security Settings window.

5 Click OK.
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Configure Pop-up Blockers
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. Contact your PeopleFluent representative for more 
information.

 Caution: Pop-up blockers must either be disabled or set to allow 
PeopleFluent Talent Management-related sites.

To configure pop-up blockers
1 Go to Tools > Internet options. 

2 On the Privacy tab, click Settings.

3 In Address of website to allow, type *.peoplefluent.com, and then click Add.

4 Repeat the process to add:

 *.peopleclick.com  The KZO video public base URL

 *.peopleclick.eu.com  The PeopleFluent Talent 
Management base URL

 *.peoplefluent.eu.com

 *.linkedin.com
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Figure 24: Pop-up Blocker Settings

5 Click Close to close the Pop-up Blocker Settings window.

6 Click OK.
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Enable Cookies

To enable cookies
1 Go to Tools > Internet options. 

2 On the Privacy tab, in Settings, click Advanced.

3 In First-party Cookies, select Accept.

Figure 25: Advanced Privacy Settings

4 Click OK to close the Advanced Privacy Settings window.

5 Click OK to close the Internet Options window.
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Allow Saving of Encrypted Pages

To allow saving of encrypted pages
1 Go to Tools > Internet options.

2 On the Advanced tab, go to Security.

3 Clear the Do not save encrypted pages to disk option. 

 Caution: Using this feature will adversely affect page performance.

Figure 26: Do not save encrypted pages to disk

4 Click OK.
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Enable Native XMLHTTP Support
PeopleFluent Talent Management requires native XMLHTTP support be enabled when 
using Microsoft Internet Explorer to view PeopleFluent Compensation worksheets with a 
fixed header. 

To enable native XMLHTTP support
1 Go to Tools > Internet options.

2 On the Advanced tab, go to Security.

3 Select the Enable native XMLHTTP support option. 

Figure 27: Enable native XMLHTTP support

4 Click OK.
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Enable HTTP 1.1 

To enable HTTP 1.1
1 Go to Tools > Internet options.

2 On the Advanced tab, go to HTTP settings.

3 Select Use HTTP 1.1.

4 Select Use HTTP 1.1 through proxy connections.

Figure 28: HTTP 1.1 Settings

5 Click OK.
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Enable TLS 1.1 and 1.2 

To enable TLS 1.1 and 1.2
1 Go to Tools > Internet options.

2 On the Advanced tab, go to Security.

3 Select Use TLS 1.1.

4 Select Use TLS 1.2.

Figure 29: TLS 1.1 and 1.2 Settings

5 Click OK.
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Enable JavaScript
JavaScript must be enabled in Internet Explorer. Clients must configure any third-party 
Internet Explorer add-ons that block JavaScript, such as NoScript.

To enable JavaScript
1 Go to Tools > Internet options.

2 On the Security tab, click Trusted sites and then click Custom level.

3 Go to Scripting > Active scripting and select Enable.

 
Figure 30: Active scripting

4 Click OK to close the Security Settings window.

5 Click OK.



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Microsoft Internet Explorer

PeopleFluent Proprietary and Confidential 43

Configure Browser Cache

To configure browser cache
1 Go to Tools > Internet options.

2 On the General tab, in Browsing history, click Settings.

3 In Check for newer versions of stored pages, select Automatically.

4 Make sure that Disk space to use is set to at least 512 MB.

Figure 31: Disk space to use

5 Click OK to close the Website Data Settings window.

6 Click OK.
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Configure for Printing

 Note: For best results, background colours and images should be included 
when printing from PeopleFluent Talent Management.

To configure for printing
1 Press ALT and go to File > Page Setup.

Figure 32: Configure Internet Explorer for Printing

2 Select Print Background Colors and Images.

3 Click OK.
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Configure for Proxy Servers

 Note: If client organisations use a proxy server, they need to use the same 
proxy server for all protocols. 

To configure for proxy servers
1 Go to Tools > Internet Options.

2 On the Connections tab, click LAN settings.

3 Click Advanced, and select Use the same proxy server for all protocols.

Figure 33: Proxy Settings
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4 Click OK to close the Proxy Settings window.

5 Click OK to close the Local Area Network (LAN) Settings window.

6 Click OK.
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Google Chrome
Clients need to make the following configuration changes to end-user browsers:

 Configure Pop-up Blockers on page 47

 Enable Cookies on page 49

 Enable JavaScript on page 51

 Open PDF Files Externally on page 52

 Configure for Proxy Servers on page 53

Administrator permissions may be required to perform browser configuration. 

 Note: Google Chrome does not allow for modification of the browser cache 
size.

Configure Pop-up Blockers
Pop-up blockers must either be disabled or set to allow PeopleFluent sites. The required 
domain names provided in this section are subject to change based on your 
organisation’s implementation. Contact your PeopleFluent representative for more 
information.

 Note: Clients must also configure any third-party pop-up blockers such as 
NoScript.

To configure pop-up blockers
1 In the Chrome address bar, type chrome://settings.

2 Click Privacy and security.

3 Click Site Settings.

4 In Site Settings, click Pop-ups and redirects.

5 Either:

 In Pop-ups, select Allowed, then go to step 10; or

 Go to step 6 to add PeopleFluent sites as exceptions.

6 In Allow, click Add.

7 In the Add a site box, type [*.]peoplefluent.com.
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8 Click Add.

9 Repeat the process to add:

Figure 34: Add a site

10 If finished making changes to your browser’s settings, close the tab.

 https://[*.]peopleclick.com  The KZO video public base URL

 https://[*.]peopleclick.eu.com  The PeopleFluent Talent 
Management base URL

 https://[*.]peoplefluent.eu.com

 https://[*.]linkedin.com
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Enable Cookies
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. The LinkedIn domain name is only required if your 
organisation is using LinkedIn integration features. The Google domain name is only 
required if your organisation is using Google Analytics. Contact your PeopleFluent 
representative for more information.

To enable cookies
1 In the Chrome address bar, type chrome://settings.

2 Click Privacy and security.

3 Click Site Settings.

4 In Site Settings, click Cookies and site data.

5 In Cookies and site data, either:

 Select Allow sites to save and read cookie data, then go to step 10; or

 Go to step 6 to add PeopleFluent sites as exceptions.

6 In Allow, click Add.

7 In the Add a site box, type [*.]peoplefluent.com.

8 Click Save.

9 Repeat the process to add:

 [*.].peopleclick.com  [*.].linkedin.com

 [*.].peopleclick.eu.com  The KZO video public base URL

 [*.].peoplefluent.eu.com  The PeopleFluent Talent 
Management base URL

 [*.].google.com



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Google Chrome

PeopleFluent Proprietary and Confidential 50

Figure 35: Cookie and site data

10 If finished making changes to your browser’s settings, close the tab.
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Enable JavaScript
JavaScript must be enabled in Chrome. Clients must also configure any third-party 
Chrome plug-ins that block JavaScript, such as NoScript.

To enable JavaScript
1 In the Chrome address bar, type chrome://settings.

2 Click Privacy and security.

3 Click Site Settings.

4 In Site Settings, click JavaScript.

5 In JavaScript, select Allowed (recommended).

Figure 36: Site Settings / JavaScript

6 If finished making changes to your browser’s settings, close the tab.
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Open PDF Files Externally
For best results when using PDF-based documents with PeopleFluent Talent 
Management, the default Chrome PDF Viewer must be disabled. This forces PDFs to 
open using the default application associated with the file format in the operating 
system.

To open PDF files externally
1 In the Chrome address bar, type chrome://settings.

2 Click Privacy and security.

3 Click Site Settings.

4 In Site Settings, click PDF documents. 

5 Select Download PDF files instead of automatically opening them in Chrome.

Figure 37: Site Settings / PDF documents

6 If finished making changes to your browser’s settings, close the tab.
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Configure for Proxy Servers
Google Chrome uses the same connection and proxy server settings as the operating 
system. 

 Note: If client organisations use a proxy server, they need to use the same 
proxy server for all protocols. 

To configure for proxy servers
1 In the Chrome address bar, type chrome://settings.

2 Click System.

3 In System, click Open your computer’s proxy settings. 

4 Consult your operating system’s instructions to configure the proxy settings for your 
organisation’s proxy server.
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Firefox
Clients need to make the following configuration changes to end-user browsers:

 Configure Pop-up Blockers on page 54

 Enable Cookies on page 56

 Enable JavaScript on page 58

 Enable Adobe Acrobat in Firefox on page 59

 Configure for Printing on page 60

 Configure for Proxy Servers on page 62

Administrator permissions may be required to perform browser configuration. 

Configure Pop-up Blockers
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. Contact your PeopleFluent representative for more 
information.

 Note: Pop-up blockers must either be disabled or set to allow PeopleFluent 
sites.

To configure pop-up blockers
1 Click the menu icon and choose Options.

2 Click Privacy & Security. 

3 Either:

 Clear Block pop-up windows to turn off Firefox’s pop-up blocker, 
then go to step 8; or

 Go to step 4 to add PeopleFluent sites as exceptions.

 Note: Clients must also configure any third-party pop-up blockers such as 
NoScript.

4 To the right of Block pop-up windows, click Exceptions.
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5 In Address of website, type https://peoplefluent.com, and then click Allow.

6  Repeat the process to add: 

Figure 38: Allowed Websites - Pop-ups

7 Click Save Changes to close the Allowed Sites - Pop-ups window.

8 Close the Options browser tab.

 https://peopleclick.com  The KZO video public base URL

 https://peopleclick.eu.com  The PeopleFluent Talent 
Management base URL

 https://peoplefluent.eu.com

 https://linkedin.com
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Enable Cookies
The required domain names provided in this section are subject to change based on your 
organisation’s implementation. The LinkedIn domain name is only required if your 
organisation is using LinkedIn integration features. The Google domain name is only 
required if your organisation is using Google Analytics. Contact your PeopleFluent 
representative for more information.

To enable cookies
1 Click the menu icon and choose Options. 

2 Click Privacy & Security.

3 In the History section, select Firefox will Use custom settings for history.

Figure 39: Privacy & Security - History

4 In the Cookies and Site Data section, click Manage Permissions.

5 Click Manage Exceptions.

6 In Address of website, type https://peoplefluent.com, and then click Allow.

7  Repeat the process to add: 

 https://peopleclick.com  https://linkedin.com

 https://peopleclick.eu.com  The KZO video public base URL

 https://peoplefluent.eu.com  The PeopleFluent Talent 
Management base URL

 https://google.com
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Figure 40: Exceptions - Cookies and Site Data

8 Click Save Changes to close the Exceptions - Cookies window.

9 Close the Options browser tab.
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Enable JavaScript
JavaScript must be enabled in Firefox. Clients must configure any third-party Firefox 
plug-ins that block JavaScript, such as NoScript.

To enable JavaScript
1 In the address bar, type about:config. A security warning appears.

Figure 41: about:config Warning

2 Click Accept the Risk and Continue. The advanced configuration page appears.

3 In Search, type javascript and press ENTER. The filtered Preferences appear. 

4 Verify that the value for javascript.enabled is set to true. 

[
Figure 42: javascript.enabled Preference Set to True

5 If the value is false, then click the Toggle icon to change the value to true.

6 Close the about:config browser tab.
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Enable Adobe Acrobat in Firefox
For best results when using PDF-based documents with PeopleFluent Talent 
Management, Adobe Acrobat in Firefox must be enabled.

To enable Adobe Acrobat in Firefox
1 Click the menu icon and choose Options.

2 Click General.

3 In Applications, type pdf in the search box. Portable Document Format (PDF) appears 
in the Content Type list.

4 In the Actions list, select Save File.

Figure 43: General - Applications

5 Close the Options browser tab.



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Firefox

PeopleFluent Proprietary and Confidential 60

Configure for Printing
For best results, background colours and images should be included when printing from 
PeopleFluent Talent Management.

To configure for printing from Firefox on Windows
1 Press ALT, then go to File > Page Setup.

2 Click Format & Options.

3 In Options, select Print Background (colors & images).

Figure 44: Format & Options

4 Click OK.
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To print from Firefox on the Mac
1 When ready to print from PeopleFluent Talent Management, go to File > Print

(or -p). 

2 In Appearance, select Print Background Colors and Print Background Images.

Figure 45: Print

3 Click other options as desired.

4 Click Print.
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Configure for Proxy Servers 
If client organisations use a proxy server, they need to use the same proxy server for all 
protocols. 

To configure for proxy servers
1 Click the menu icon and choose Options.

2 Click General.

3 In Network Settings, click Settings.

Figure 46: General - Network Settings

4 Enter the information appropriate for your organisation’s proxy server.

5 Click OK to close the Connection Settings dialog box.

6 Close the Options browser tab.



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Safari

PeopleFluent Proprietary and Confidential 63

Safari
Clients need to make the following configuration changes to end-user browsers:

 Configure Pop-up Blockers on page 63

 Enable JavaScript on page 64

 Accept Cookies on page 65

 Configure Proxy Servers on page 66

 About Printing from Safari on page 67

Configure Pop-up Blockers
Pop-up blockers must either be disabled or set to allow PeopleFluent sites.

To configure pop-up blockers
1 Go to Safari > Preferences (or -,). 

2 Click Security. 

3 Clear Block pop-up windows to turn off Safari’s pop-up blocker.

Figure 47: Preferences - Security

4 Close the Preferences window.
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Enable JavaScript
PeopleFluent Talent Management requires JavaScript be allowed to run in Safari.

To enable JavaScript
1 Go to Safari > Preferences (or -,). 

2 Click Security.

3 Select Enable JavaScript.

Figure 48: Preferences - Security

4 Close the Preferences window.

 Note: Clients must also configure any third-party extensions that block 
JavaScript.
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Accept Cookies
PeopleFluent Talent Management requires Safari be allowed to store cookies.

To enable cookies
1 Go to Safari > Preferences (or -,). 

2 Click Privacy.

3 In Cookies and website data, clear Block all cookies.

Figure 49: Preferences - Privacy

4 Close the Preferences window.
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Configure Proxy Servers
If client organisations use a proxy server, they need to use the same proxy server for all 
protocols. 

To configure proxy servers
1 Go to Safari > Preferences (or -,). 

2 Click Advanced.

3 In Proxies, click Change Settings. The macOS Network window appears.

4 Enter the information appropriate for your organisation’s proxy server.

5 Close the Network window.

6 Close the Preferences window.
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About Printing from Safari
For best results, background colours and images should be included when printing from 
PeopleFluent Talent Management.

To print from Safari
1 When ready to print from PeopleFluent Talent Management, go to File > Print

(or -p). 

2 Click the disclosure triangle next to the Printer pop-up menu to expand the Print 
window.

3 Select Safari.

4 Select Print backgrounds.

Figure 50: Print

5 Select other options as desired.

6 Click Print.
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Use of Multiple Browser Tabs and Windows
Many web browsers allow users to open multiple windows and some web browsers 
support tabbed browsing. For best results, PeopleFluent recommends accessing 
PeopleFluent Talent Management in only one browser tab within a single browser 
window per user session. 

 Caution: Accessing PeopleFluent Talent Management in multiple browser 
windows or tabs may produce unexpected results.

Email

Anti-Spamming
Many organisations use email anti-spamming technology to filter out unwanted or 
suspect emails. Parts of PeopleFluent Talent Management use built in email functionality 
to send information to PeopleFluent Talent Management users. Some enterprise email 
anti-spamming technology may interpret this type of email as suspect and therefore not 
deliver the message. This issue is due to the email message containing the 
organisation’s domain name (…@organisation.com), yet having a corresponding IP 
address signature that is outside the organisation’s IP address range.

If your organisation has implemented this anti-spam technology or if you are 
experiencing email difficulties using PeopleFluent Talent Management, the remainder of 
this section should be reviewed.

Email Domain Whitelisting
PeopleFluent recommends that all clients whitelist emails from any PeopleFluent server. 
Any email sent from a server with the following reverse DNS look-up values should be 
whitelisted based on the location of PeopleFluent datacenter where your organisation’s 
application is hosted:

Table 3: Datacenter Locations and Email Server Domains

PeopleFluent Datacenter Location Email Server Domain

Atlanta pc-mail.peopleclick.com

London pc-mail.peopleclick.eu.com

Toronto pc-mail.peoplefluent-ca.com
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IP Address Whitelisting
If your organisation’s spam filtering software is unable to whitelist domains, 
PeopleFluent can provide the IP addresses from which production email messages are 
currently sent. PeopleFluent will normally have a primary set of IP address ranges from 
which emails can be sent, although additional ranges may be used to accommodate load 
balancing, redundancy, and future expansion. Additionally, PeopleFluent may change one 
or more of the IP address ranges to accommodate changes in our engineering, 
architecture or infrastructure. PeopleFluent may also remove or add IP address ranges 
for the same purpose.

Non-production PeopleFluent environments may send email from separate IP addresses. 
These IP addresses are subject to change and therefore need to be requested separately. 
Whitelists and other anti-spam management tools should be configured to accept mail 
from both production and non-production sources.

PeopleFluent will provide as much notice as possible to clients regarding changes to the 
IP address ranges. 

For these reasons, PeopleFluent recommends that clients whitelist the PeopleFluent 
domains rather than individual IP addresses. 

Desktop Management
Anti-spamming technology can reside on an individual’s device as well as at the 
enterprise level. If your organisation relies on anti-spamming technology using an email 
client, you may also need to modify the policies of these email applications to 
accommodate the published IP address ranges PeopleFluent uses for email 
communication.

Sender Policy Framework
Email recipients that have external email addresses may have spam prevention that 
prevents email from being sent from a domain that does not match the domain that is 
sending the email. This is especially important for applicants, which recruiters may be 
sending email about application status, interviews, offer letters, onboarding and 
opportunities. To validate that an email is valid, PeopleFluent recommends adding 
Sender Policy Framework (SPF) records to the client’s public Domain Naming System 
(DNS) infrastructure. An SPF record enables email servers to validate that the sender is 
allowed to send emails from the client’s domain. An SPF record needs to be added to the 
client’s public DNS to allow any potential recipient’s email server to query DNS and 
validate that the IP address of the sending server is valid for the client’s domain. These 
public SPF records will need to be added by the client’s DNS administrator. 



PeopleFluent Talent Management 21.07
Hardware and Software Requirements Sender Policy Framework

PeopleFluent Proprietary and Confidential 70

PeopleFluent maintains a record in public DNS called spf.peopleclick.com that has all the 
addresses that are used to send email from PeopleFluent applications. To avoid client 
DNS administrators from having to keep up with PeopleFluent IP addresses and host 
names, and to limit the number of DNS queries required for SPF validation, PeopleFluent 
recommends adding just this hostname to the SPF record.

Example: 

company.comIN TXT "v=spf1 a:spf.peopleclick.com ?all"

This record is an example for an organisation that currently does not do any SPF 
validation for their own email but would like to allow external email addresses to validate 
SPF and show that PeopleFluent email servers are allowed to send from the 
company.com domain. The ?all qualifier at the end of the SPF record treats all other 
email as if there were no SPF policy in place and thereby allows email sent from other 
sources to continue to be received.

Clients who experience issues with emails not being received due to SPF validation 
reasons may already have an SPF entry with the -all qualifier which rejects all email 
senders not specified in the policy.

Contact your PeopleFluent representative to request assistance with any questions about 
SPF validation.
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Supporting Applications
This section describes the supporting applications that are recommended for use with 
PeopleFluent Talent Management.

Mail Client/Calendar System
PeopleFluent Talent Management sends email in text and HTML format, and meeting 
invitations in iCAL (.ics) format. Check with your mail client/calendar system vendor for 
compatibility.

Word Processor
PeopleFluent Talent Management supports over 100 file formats for attachments, 
resume search, and resume parsing, including:

 ANSI text

 ASCII text

 HTML

 Adobe Portable Document Format (PDF)

 Microsoft Rich Text Format (RTF)

 Microsoft Word 2013

 Microsoft Word 2016

 Open Office Word Processing
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 Caution: Please be aware of the following:

 PeopleFluent Talent Management does not support parsing image files 
such as a resume scanned (without OCR) and saved as a PDF. 

 The wide selection of tools available for generating PDFs and their 
varying support for the PDF file format make it impossible to identify a 
single version of PDF that PeopleFluent Talent Management supports 
for resume parsing and preview. 

 While PeopleFluent Talent Management can generate a preview of most 
resumes, if you cannot preview one, you can always view the original file 
attached to the candidate or contact document. Alternatively, users can 
upload the resume in another format, such as HTML, text, Microsoft 
Word, or Open Office, as those formats are more likely to be rendered 
correctly in a preview. 

SmartGrid Export
PeopleFluent Talent Management provides the ability to export any SmartGrid as a 
comma separated value (.csv) file. While many applications support this format, 
PeopleFluent tested this feature using Microsoft Excel 2013 and Microsoft Excel 2016.

Report Output
PeopleFluent Talent Management provides the ability to save report results in several file 
formats. The following table lists the file formats and the versions of applications with 
which they were tested:

Table 4: Report Output Formats and Tested Applications

Format Tested Applications

Excel  Microsoft Excel 2016
 Microsoft Excel 2013

PDF  Adobe Reader DC 2019

Word  Microsoft Word 2016
 Microsoft Word 2013

PPT  Microsoft PowerPoint 2016
 Microsoft PowerPoint 2013
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 Note the following:

 PeopleFluent Talent Management also exports to XML and comma-
separated value (CSV) data formats.

 Reports exported to Microsoft Excel do not include charts or graphics, 
such as logos.

 Report output in PPT format may be opened and viewed in a limited 
presentation mode in a web browser, but must be saved to a file before 
opening in Microsoft PowerPoint for editing or printing.

Report Customisations
PeopleFluent Talent Management provides the ability to customise reports and 
statements using Business Intelligence and Reporting Tools (BIRT). BIRT is an open-
sourced, Java-based visual report development plug-in to the Eclipse SDK. Users 
customising reports will need the following applications:

 OpenJDK Version 8

 BIRT 3.7.2

 Eclipse SDK 3.7.2 RC4

 Note the following:

 BIRT is only required for those few administrators who are responsible 
for customising reports and statements. It is not a requirement for every 
end user.

 PeopleFluent recommends downloading the BIRT All-in-One Package 
which includes BIRT and Eclipse. 
http://download.eclipse.org/birt/downloads

 Caution: Clients who want to customise reports must contact PeopleFluent 
Support before instaling and using BIRT.
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Online Job Forms
PeopleFluent Talent Management supports the use of Adobe Acrobat PDF-based online 
job forms. Clients can attach these forms to job postings and require candidates to 
complete them when they submit their resumes. 

 Form Authors: Adobe LiveCycle Designer 8.2.1 ES or later

 Candidates: Adobe Acrobat Reader 8.1 or later with JavaScript enabled and set to 
display PDF in browser

To enable JavaScript in Adobe Reader
1 Open Adobe Reader.

2 Click Edit > Preferences.

3 In Categories, click JavaScript.

4 In the JavaScript section, select Enable Acrobat JavaScript.

Figure 51: Preferences - JavaScript

5 Click OK.
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Onboarding Forms

HTML-Based Forms
PeopleFluent Onboarding allows onboarding administrators to create HTML forms which 
can then be mapped to Adobe Acrobat PDF-based forms. Authors of HTML-based forms 
that want to map them to PDF forms must instal Adobe LiveCycle Designer 8.2.1 ES or 
later (to create a PDF form) or Adobe Acrobat Pro (to scan an existing hard copy form).

PDF-Based Forms
PeopleFluent Onboarding allows onboarding administrators to create PDF forms which 
can then be mapped to fields in PeopleFluent Onboarding. Authors of PDF-based forms 
should instal Adobe Acrobat Pro to design PDF-based forms.

HTML Forms
PeopleFluent Recruiting allows recruiting administrators to create HTML forms which 
can then be mapped to Adobe Acrobat PDF-based forms. PDF form authors must instal 
Adobe LiveCycle Designer 8.2.1 ES or later to create a PDF form.
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Integration with Other PeopleFluent Applications
This section lists the requirements for integrations between PeopleFluent Talent 
Management and other PeopleFluent applications.

PeopleFluent OrgPublisher
PeopleFluent Talent Management supports integration with PeopleFluent OrgPublisher. 
This requires PeopleFluent Talent Management 11.3 or later and PeopleFluent 
OrgPublisher 11.3 or later.

 Note: Occasionally, PeopleFluent adds or modifies columns on the 
SmartGrids used by this integration. If client-specific modifications have 
been made to any of these SmartGrids, they may need to be manually 
reapplied by a trained PeopleFluent representative after upgrading to 
PeopleFluent Talent Management 21.07. For more information, see the 
PeopleFluent Talent Management Release Notes.

PeopleFluent iPaaS
PeopleFluent Talent Management supports integration with PeopleFluent iPaaS. Contact 
your PeopleFluent representative for more information.

PeopleFluent Learning
PeopleFluent Talent Management supports integration with PeopleFluent Learning, 
except on the Apple Safari browser. Integrated features in this update require 
PeopleFluent Learning 11.18.0.x and are not compatible with previous updates. 

Productivity Platform
PeopleFluent Talent Management supports integration with the PeopleFluent 
Productivity Platform. The user interface refresh changes for existing Talent 
Management microapps and the Onboarding Task microapp added in the PeopleFluent 
Talent Management 21.04 update are only compatible with the dashboard in 
PeopleFluent Productivity Platform 2.0 update.

Socialtext 
PeopleFluent Talent Management supports integration with Socialtext 8.10.0.0.
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Configuring User Keyboards for Multilingual 
Content

The QWERTY keyboard layout is required for PeopleFluent Talent Management. If users 
are required to enter or manage multilingual data in PeopleFluent Talent Management, 
clients should consult the operating system’s documentation to configure their users’ 
keyboards to generate special characters and accents relevant to additional or alternate 
languages.
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Legal Notices

This document has been created for authorised licensees and subscribers (“Customers”) of the software products and associated 
services of PeopleFluent, Inc. and all of its affiliates (individually and collectively, as applicable, “PeopleFluent”). It contains the 
confidential and proprietary information of PeopleFluent and may be used solely in accordance with the agreement governing 
the use of the applicable software products and services. This document or any part thereof may not be reproduced, translated 
or retransmitted in any form without the written permission of PeopleFluent. The information in this document is subject to 
change without notice.

PEOPLEFLUENT DISCLAIMS ALL LIABILITY FOR THE USE OF THE INFORMATION CONTAINED IN THIS DOCUMENT AND MAKES NO 
REPRESENTATIONS OR WARRANTIES WITH RESPECT TO ITS ACCURACY OR COMPLETENESS. PEOPLEFLUENT DISCLAIMS ALL 
IMPLIED WARRANTIES INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. 
PEOPLEFLUENT DOES NOT GUARANTEE THAT ITS PRODUCTS OR SERVICES OR ANY SAMPLE CONTENT CONTAINED IN ITS 
PRODUCTS AND SERVICES WILL CAUSE OR ENABLE CUSTOMER TO COMPLY WITH LAWS APPLICABLE TO CUSTOMER. USERS ARE 
RESPONSIBLE FOR COMPLIANCE WITH ALL LAWS, RULES, REGULATIONS, ORDINANCES AND CODES IN CONNECTION WITH THE 
USE OF THE APPLICABLE SOFTWARE PRODUCTS, INCLUDING, WITHOUT LIMITATION, LABOUR AND EMPLOYMENT LAWS IN 
RELEVANT JURISDICTIONS. THE PEOPLEFLUENT PRODUCTS AND SAMPLE CONTENT SHOULD NOT BE CONSTRUED AS LEGAL 
ADVICE.

Without limiting the generality of the foregoing, PeopleFluent may from time to time link to third-party web sites in its products 
and/or services. Such third-party links are for demonstration purposes only, and PeopleFluent makes no representations or 
warranties as to the functioning of such links or the accuracy or appropriateness of the content located on such third-party sites. 
You are responsible for reviewing all content, including links to third-party web sites and any content that you elect to use, for 
accuracy and appropriateness, and compliance with applicable law.

Any trademarks included in this documentation may comprise registered trademarks of PeopleFluent in the United States and in 
other countries.

Microsoft, Windows, and Internet Explorer are trademarks or registered trademarks of Microsoft Corporation in the United 
States and/or other countries. Oracle and PeopleSoft are registered trademarks of Oracle International Corporation. Adobe and 
Acrobat are registered trademarks of Adobe Systems Incorporated. All other names are used for identification purposes only and 
are trademarks or registered trademarks of their respective owners. Portions of PeopleFluent Workforce Communication 
software include technology licensed from Autonomy and are the copyright of Autonomy, Inc. Quartz Scheduler is licensed under 
the Apache License, Version 2.0. Copyright (c) 2001-2010 Terracotta, Inc. 

Website: www.peoplefluent.com 

Copyright © 2021, Learning Technologies Group, Inc. All rights reserved. 
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